Mike Durran

Update to requirejs for OAC 6.0

This is a quick tip to let you know that if you’re embedding Oracle Analytics Cloud (OAC) canvases and your instance has been upgraded to OAC 6.0, you need to make a change to your embedding code to include some additional dependencies in the requirejs statement.

If your existing requirejs statement looks like this:

requirejs(['jquery', 'knockout', 'obitech-application/application', 'jet-composites/oracle-dv/loader']

Please modify it so it looks like this:

requirejs(['jquery', 'knockout', 'obitech-application/application', 'ojs/ojcore', 'ojs/ojknockout', 'ojs/ojcomposite', 'jet-composites/oracle-dv/loader']

--

--

Mike Durran

Mike Durran

Analytics Product Manager at Oracle. [All content and opinions are my own]